PHP-GTK.eu End of Life and GDPR

If you're reading the PHP-GTK.eu community site these days, you certainly noticed that not a single piece of significant content was created since 2015, and not much since 2013.

Whatever this may mean for PHP-GTK itself is another issue, but for the site itself, it means it ceased to be relevant about 5 years ago, and it's time to move on for the site members. Since the site contains non-anonymous user, it will fall under the new EU GDPR regulations entering into force on 2018-05-25, and there is no point for me to spend time on evolving the site towards compliance when no one is actually using it.

So here is the EOL announcement: the site will be shutting down on 2018-05-24 and its data will taken offline.

A static version of the articles may be published again at some point here or elsewhere, but I wouldn't hold my breath on it. So if you have even some interest in the site content, be sure to copy/paste the pages of interest before it goes dark on 2018-05-24. Or contact me if you want a copy of the files and content, or check my blog for newer content.

Thanks all for participating, it's been a pleasure while it lasted.

FGM

Where can i get php-gtk2.20 for windows

Hi,

Please can any one help me where can i download php-gtk2 of version 2.20, please can any one post the url / can any one give me the steps to compile for my windows

Thanks

Use the tutorials

There are a number of installation tutorials, starting at http://php-gtk.eu/en/installation-tutorials

You probably should start there.

If you mean gtk 2.20, then

If you mean gtk 2.20, then you just have to download a the gtk 2.20 package for windows and replace the libraries on the default php-gtk package, however there might be some libs that are not used since php-gtk might have been compiled against a different versión of libgtk, but most of the "standard" php-gtk2 functions should work just fine though.
Also the installer I created using Inno (@see "PHP-GTK installer for windows") it's using a newer php-gtk build (using cairo) and gtk 2.22 libs, so it might work for what you need.

Regards
Orlando Saavedra

Volby prohlížení komentářů

Vyberte si, jak chcete zobrazovat komentáře a klikněte na "Uložit změny".